Resultados 1 al 1 de 1






reinicio no va


Estás en el tema reinicio no va dentro del subforo GigaBlue HD 800 se en LonasDigital. Hasta el momento todo va ok, lo que pasa es que cuando reinicio no me arranca ni el mbox ni el sbox, lo tengo que hacer desde telnet y despues reinicio enigma 2 y funciona todo. estos son los script que tengo en /usr/camscript/ Ncam_mbox_sbox.sh __________________ #!/bin/sh CAMNAME="Mbox - Sbox" remove_tmp () { rm -rf /tmp/*.info* /tmp/*.tmp*...



Este tema tuvo 489 Visitas y 0 Respuestas

Actualmente hay 1 usuarios viendo este tema. (0 miembros y 1 visitantes)

  1. #1
    Avatar de wuanipepe

    wuanipepe ha iniciado este hilo.
    wuanipepe está desconectado
    Título:  Usuario VIP Rango:  Usuario VIP
    Fecha de ingreso
    Nov-2010
    Nacionalidad
    Espana
    Temas
    45
    Mensajes
    122


    Hasta el momento todo va ok, lo que pasa es que cuando reinicio no me arranca ni el mbox ni el sbox, lo tengo que hacer desde telnet y despues reinicio enigma 2 y funciona todo.
    estos son los script que tengo en /usr/camscript/

    Ncam_mbox_sbox.sh
    __________________
    #!/bin/sh

    CAMNAME="Mbox - Sbox"
    remove_tmp () {
    rm -rf /tmp/*.info* /tmp/*.tmp*
    }
    case "$1" in
    start)
    echo "[SCRIPT] $1: $CAMNAME"
    remove_tmp
    /usr/bin/ntpdate -v -b hora.rediris.es >> /tmp/ntpdate.log
    sleep 2
    /usr/bin/sbox &
    sleep 5
    sh /usr/script/sboxtest.sh &
    sleep 1
    sed -i '/A: { 1 }/d' /usr/keys/mbox.cfg
    if ! grep '^P:.*' /usr/keys/mbox.cfg > /dev/null
    then
    echo "P: { 2/tmp/camd.socket }" >> /usr/keys/mbox.cfg
    fi
    /usr/bin/mbox > /dev/null &
    ;;
    stop)
    echo "[SCRIPT] $1: $CAMNAME"
    killall sbox 2>/dev/null
    touch /tmp/mbox.kill
    sleep 10
    killall -9 sbox 2>/dev/null
    killall -9 mbox 2>/dev/null
    remove_tmp
    ;;
    *)
    $0 stop
    exit 0
    ;;
    esac
    exit 0


    Ncam_mbox.sh
    ------------------
    #!/bin/sh

    CAMNAME="Mbox"
    remove_tmp () {
    rm -rf /tmp/*.info* /tmp/*.tmp*
    }
    case "$1" in
    start)
    echo "[SCRIPT] $1: $CAMNAME"
    remove_tmp
    /usr/bin/ntpdate -v -b hora.rediris.es >> /tmp/ntpdate.log
    sleep 2
    sed -i '/A: { 1 }/d' /usr/keys/mbox.cfg
    if ! grep '^P:.*' /usr/keys/mbox.cfg > /dev/null
    then
    echo "P: { 2/tmp/camd.socket }" >> /usr/keys/mbox.cfg
    fi
    /usr/bin/mbox > /dev/null &
    ;;
    stop)
    echo "[SCRIPT] $1: $CAMNAME"
    touch /tmp/mbox.kill
    sleep 10
    killall -9 mbox 2>/dev/null
    remove_tmp
    ;;
    *)
    $0 stop
    exit 0
    ;;
    esac
    exit 0

    a ver si alguien me dice que falla, son los dos únicos script que tengo en camscript, falta algo ?

    Temas similares:
    Última edición por wuanipepe; 25-04-13 a las 20:38 Razón: corregir


    Citar Citar  




Subir