Resultados 1 al 3 de 3






[Tutorial] Instalación de Enigmalight


Estás en el tema [Tutorial] Instalación de Enigmalight dentro del subforo Receptores General (Dudas) en LonasDigital. Hola, después de mucho leer y ver cómo funciona este sistema, me decidí a pedir el material necesario para su instalación. Decir que toda la información la saqué de www.enigmalight.net y de los enlaces que esa página contiene. Es en ésta página donde está el plugin IPK para instalar en el deco así como enlace al foro del soporte y demás. A continuación, indico que elementos hacen falta para montar un sistema como este. Lo primero de todo fue pedir el material y como lo pedí a la...



Este tema tuvo 943 Visitas y 2 Respuestas

Actualmente hay 1 usuarios viendo este tema. (0 miembros y 1 visitantes)

  1. #1
    Avatar de jarro_25

    jarro_25 ha iniciado este hilo.
    jarro_25 está desconectado
    Título:  Usuario PREMIUM Rango:  Usuario PREMIUM
    Fecha de ingreso
    Mar-2014
    Receptor
    800UE+ Combo
    Firmware
    OpenLD 1.8
    Nacionalidad
    Espana
    Ubicación
    La Rioja
    Temas
    7
    Mensajes
    234


    Hola, después de mucho leer y ver cómo funciona este sistema, me decidí a pedir el material necesario para su instalación.

    Decir que toda la información la saqué de www.enigmalight.net y de los enlaces que esa página contiene. Es en ésta página donde está el plugin IPK para instalar en el deco así como enlace al foro del soporte y demás.


    A continuación, indico que elementos hacen falta para montar un sistema como este.

    Lo primero de todo fue pedir el material y como lo pedí a la china, pues mientras tuve tiempo de medir la tele y mandar que me hicieran una plancha de aluminio con las medidas que yo creí oportunas para posteriormente colocar los leds:
    [IMG]http://**********.com/a/img661/3978/r7TbUe.jpg[/IMG]


    Los leds, hay varios tipos que se pueden usar, yo he elegido los w2801, son estos:
    [IMG]http://**********.com/a/img908/4516/kuTsij.jpg[/IMG]

    Una placa arduino Uno (compré una pirata y de momento no funciona, igual es por esto no se):
    [IMG]http://**********.com/a/img538/5420/6FzgkX.jpg[/IMG]

    Unos cables para hacer puente
    [IMG]http://**********.com/a/img908/9482/IVHwdb.jpg[/IMG]

    Una fuente de alimentación




    Bueno, pues al lío.
    Sobre la plancha de aluminio me hago un pequeño esquema en el que voy marcando la distancia a la que quiero poner los leds:

    [IMG]http://**********.com/a/img674/3746/YeQnuO.jpg[/IMG]


    Una vez marcada la distancia y saber cuantos voy a colocar, hago unos agujeros para poder fijar los leds mediante bridas une:
    [IMG]http://**********.com/a/img913/9530/YRflZg.jpg[/IMG]

    Fijo también el arduino aislándolo primeramente con un poco de cartón y goma eva para que no me haga corto en la plancha de aluminio también mediante bridas une

    Ahora llega la hora de conectar los cables de los leds al arduino. Esto es bastante sencillo tan sólo se conectan 3 cables, el azul a cualquier gnd, el verde al pin 13 y el amarillo al pin 11. IMPORTANTE: hay que hacer la conexión al principio de los leds. NO EN EL FINAL.
    Despues de tener conectado los leds al arduino, llega la hora de conectar a la corriente en el otro extremo de los leds. Yo compré una tira de 50 leds y solamente use 39, así que los restantes, un tijeretazo y fuera:
    [IMG]http://**********.com/a/img673/7140/TKFtGa.jpg[/IMG]

    Compruebo la polaridad del transformador:
    [IMG]http://**********.com/a/img538/6137/DbTf6s.jpg[/IMG]

    Una vez instalado todo tal como me ha quedado:
    [IMG]http://**********.com/a/img913/1525/AeXX8t.jpg[/IMG]

    Bien, ahora llega la hora de programar el arduino.
    Imprescindible tener el software Arduino IDE instalado antes de conectar la placa arduino por usb al pc. Conectamos la placa arduino, cargamos un fichero llamado ledstream.pde y al finalizar la carga si tienes el transformador enchufado debería hacer un pequeño test de rgb:



    Una vez programado el arduino, nos vamos al deco e instalamos el plugin enigmalight.ipk la última versión, más adelante pondré enlaces de todas las fuentes donde me he informado. Instalado el plugin le hacemos un reinicio al deco y conectamos los leds, ahora sería el tiempo de configurar los leds mediante el enigmalight.conf


    Y de momento aquí me he quedado, he probado varias configuraciones y no se si es por el fichero que no lo configuro bien o es que la placa CHINA Arduino Uno que he comprado no funciona para este menester.

    Edito: en el fichero de configuración hay que meter un prefix el cual creo que indica los leds que tenemos y se calcula de la siguiente manera:
    Código:
    /home/elight-addons/prefix 92
    Eso por ejemplo creo que es para 92 leds. Yo ahí le coloqué el 39 y ahora al menos me arranca. Aunque no puedo ver si encienden los leds pues no estoy en casa.
    A medio día probaré si funciona bien y comentaré o grabaré un vídeo.

    Lo he montado todo por un precio creo que más que razonable:
    50 x leds ws2801 25€
    fuente de alimentación x 2 8€ (compré dos, ya que por el precio si se rompe una no tengo que esperar un mes que llegue otra)
    Arduino Uno chino x 1 8€
    Cables de conexionado x 50 1,50€
    Plancha de aluminio 10€

    TOTAL QUE POR 52.50€ Y 1 hora u hora y media de trabajo tengo Ambilight para rato y aunque cambie de televisión seguirá funcionando a través del deco.


    Espero que os guste este pequeño tutorial, por si alguien quisiera montarlo que lo tenga un poco más fácil.

    Un saludo.

    Última edición por jarro_25; 12-11-14 a las 13:39 Razón: Publicar fuentes originales


    Citar Citar  

  2. Los siguientes 2 Usuarios dieron las gracias a jarro_25 Por su Mensaje :

    caphowdy (12-11-14), Puskis (12-11-14)


  3. QoinPro.com: Free Bitcoins every 24 hours


  4. #2
    Avatar de jarro_25

    jarro_25 ha iniciado este hilo.
    jarro_25 está desconectado
    Título:  Usuario PREMIUM Rango:  Usuario PREMIUM
    Fecha de ingreso
    Mar-2014
    Receptor
    800UE+ Combo
    Firmware
    OpenLD 1.8
    Nacionalidad
    Espana
    Ubicación
    La Rioja
    Temas
    7
    Mensajes
    234


    Reservado 1


    Citar Citar  

  5. #3
    Avatar de jarro_25

    jarro_25 ha iniciado este hilo.
    jarro_25 está desconectado
    Título:  Usuario PREMIUM Rango:  Usuario PREMIUM
    Fecha de ingreso
    Mar-2014
    Receptor
    800UE+ Combo
    Firmware
    OpenLD 1.8
    Nacionalidad
    Espana
    Ubicación
    La Rioja
    Temas
    7
    Mensajes
    234


    Pues lo he probado esta medio día y sí encienden los leds cuando entro al plugin enigmalight y lo activo hace un test rgb y luego se quedan las luces fijas en color blanco y no refresca los colores.
    Sigo pensando que es algo que se me escapa del enigmalight.conf.
    Esta noche escribiré en el hilo del autor si puede decirme como solucionarlo.

    Un saludo


    Citar Citar  

  6. Los siguientes usuarios agradecieron a jarro_25 por su mensaje :

    Puskis (12-11-14)

Subir