Página 1 de 3 123 ÚltimoÚltimo
Resultados 1 al 20 de 44






Oscam con reader newcamd se desconecta


Estás en el tema Oscam con reader newcamd se desconecta dentro del subforo Oscam en LonasDigital. Hola, Estoy tratando de hacer funcionar oscam con una N line que creo de mi abono usando sbox. La Nline funciona perfectamente. Y en oscam tambien funciona bien , salvo por un incoveniente. Se me desconecta sola a los 150 segundos si no recibe ninguna peticion. He estado buscando informacion a ver si encuentro alguna opcion de keepalive en newcamd como cliente de una Nline en oscam y no hay nada. Probe a ponerle en el reader newcamd keepalive = 1 pero no hace caso. Se sigue desconectando....



Este tema tuvo 8537 Visitas y 43 Respuestas

Actualmente hay 1 usuarios viendo este tema. (0 miembros y 1 visitantes)

  1. #1
    Avatar de Odonk

    Odonk ha iniciado este hilo.
    Odonk está desconectado
    Título:  Amigo de Lonas Rango:  Amigo de Lonas
    Fecha de ingreso
    Apr-2011
    Nacionalidad
    Espana
    Temas
    7
    Mensajes
    69


    Hola,

    Estoy tratando de hacer funcionar oscam con una N line que creo de mi abono usando sbox. La Nline funciona perfectamente. Y en oscam tambien funciona bien , salvo por un incoveniente. Se me desconecta sola a los 150 segundos si no recibe ninguna peticion.

    He estado buscando informacion a ver si encuentro alguna opcion de keepalive en newcamd como cliente de una Nline en oscam y no hay nada. Probe a ponerle en el reader newcamd keepalive = 1 pero no hace caso. Se sigue desconectando. Tambien probe a ponerlo en el oscam.conf seccion newcamd y nada.

    En el log de oscam pone esto cuando se desconecta:

    [newcamd] disconnected: reason inactivity

    Que hago para que no se desconecte la Nline en oscam ?

    He probado la Nline en CCcam nativo y alli no se desconecta nunca.

    SOLUCIONADO:

    El problema esta en que las lineas N creadas por el sbox se desconectaban por inactividad timeout. Creando la linea de la siguiente manera se soluciona:

    NC=usuario contraseña slot0 0 -1

    Importante ese -1 en la linea en el lugar donde se pone el timeout. Con eso la linea N del sbox puesta en un oscam ya no se desconecta.


    Última edición por Odonk; 10-02-15 a las 16:23


    Citar Citar  

  2. Los siguientes usuarios agradecieron a Odonk por su mensaje :

    nlucho77 (01-03-15)


  3. QoinPro.com: Free Bitcoins every 24 hours


  4. #2
    Avatar de miquelcamps

    miquelcamps está desconectado
    Título:  Amigo de Lonas Rango:  Amigo de Lonas
    Fecha de ingreso
    Oct-2006
    Receptor
    VU+uno
    Firmware
    OpenVix
    Ubicación
    Catalunya
    Temas
    4
    Mensajes
    50


    El keepalive lo tienes en la configuracion general (oscam.conf), en en apartado de newcamd, con esto te lo tiene que mantener en marcha, activa tambien en el reader el connect on init, ( connectoninit = 1 )
    Última edición por miquelcamps; 07-02-15 a las 11:00


    Citar Citar  

  5. #3
    Avatar de Odonk

    Odonk ha iniciado este hilo.
    Odonk está desconectado
    Título:  Amigo de Lonas Rango:  Amigo de Lonas
    Fecha de ingreso
    Apr-2011
    Nacionalidad
    Espana
    Temas
    7
    Mensajes
    69


    Si, ya tenia puesto todo eso y no se mantiene conectado.

    No puedo creer el oscam que tiene mil y unas opciones de configuracion, a dia de hoy no tenga contemplada dicha opcion en las Nline.


    Citar Citar  

  6. #4
    Avatar de miquelcamps

    miquelcamps está desconectado
    Título:  Amigo de Lonas Rango:  Amigo de Lonas
    Fecha de ingreso
    Oct-2006
    Receptor
    VU+uno
    Firmware
    OpenVix
    Ubicación
    Catalunya
    Temas
    4
    Mensajes
    50


    Que tienes puesto en inactivity time out? , lo tienes en el reader, debajo del connect on init, mirandolo por el webif


    Citar Citar  

  7. Los siguientes usuarios agradecieron a miquelcamps por su mensaje :

    Odonk (07-02-15)

  8. #5
    Avatar de Odonk

    Odonk ha iniciado este hilo.
    Odonk está desconectado
    Título:  Amigo de Lonas Rango:  Amigo de Lonas
    Fecha de ingreso
    Apr-2011
    Nacionalidad
    Espana
    Temas
    7
    Mensajes
    69


    Si lo tengo puesto. Lo probe con 140, con 1 y con -1 Y sigue igual en los 3 casos.

    El connectinit tambien lo tengo, es obligatorio ponerlo porque sin esto no conecta nunca.


    Citar Citar  

  9. #6
    Avatar de miquelcamps

    miquelcamps está desconectado
    Título:  Amigo de Lonas Rango:  Amigo de Lonas
    Fecha de ingreso
    Oct-2006
    Receptor
    VU+uno
    Firmware
    OpenVix
    Ubicación
    Catalunya
    Temas
    4
    Mensajes
    50


    El connect on init es para que se conecte la N sin necesidad de se le haga ninguna peticion, creo que es lo que quieres ¿no?
    luego el inactivity time out ponlo a 0
    una cosa mas cuando hagas algun cambio en la configuracion de oscam, si lo haces por el archivo con dcc, hazlo con el oscam apagado, guarda los cambios, y luego lo pones en marcha, si lo haces por el webif, muchas opciones no necesitan reiniciar, pero algunas si


    Citar Citar  

  10. Los siguientes usuarios agradecieron a miquelcamps por su mensaje :

    Odonk (07-02-15)

  11. #7
    Avatar de Odonk

    Odonk ha iniciado este hilo.
    Odonk está desconectado
    Título:  Amigo de Lonas Rango:  Amigo de Lonas
    Fecha de ingreso
    Apr-2011
    Nacionalidad
    Espana
    Temas
    7
    Mensajes
    69


    Ya hago todo eso, y no funciona. Siempre killall -9 oscam hago los cambios, guardo y arranco oscam. Probado el connectinit, el inactivitytimeout a 0 y nada de nada.

    Gracias por tu interes y ayuda. Por cierto que no lo dije. Probado con varias versiones de oscam , incluida una de las mas nuevas.
    Última edición por Odonk; 07-02-15 a las 14:36


    Citar Citar  

  12. #8
    Avatar de miquelcamps

    miquelcamps está desconectado
    Título:  Amigo de Lonas Rango:  Amigo de Lonas
    Fecha de ingreso
    Oct-2006
    Receptor
    VU+uno
    Firmware
    OpenVix
    Ubicación
    Catalunya
    Temas
    4
    Mensajes
    50


    Yo tengo varias Nlines en oscam y no se me desconectan nunca, tienes que tener algo mal, pon tu configuracion sin datos comprometidos y lo miro
    leyendo tu primer post dices que siempre se desconecta a los 150 segundos? esto es siempre así? porque tiene pinta de que tienes algun timeout con 150 segundos, puedes mirar esto tambien, en toda la configuracion donde tienes 150 o 150.000 milisegundos


    Citar Citar  

  13. Los siguientes usuarios agradecieron a miquelcamps por su mensaje :

    Odonk (07-02-15)

  14. #9
    Avatar de Odonk

    Odonk ha iniciado este hilo.
    Odonk está desconectado
    Título:  Amigo de Lonas Rango:  Amigo de Lonas
    Fecha de ingreso
    Apr-2011
    Nacionalidad
    Espana
    Temas
    7
    Mensajes
    69


    Si, lo de los 150 segundos lo marca el sbox en su configuracion por defecto. Y no creo que sea esto por usando el CCcam la Nline no se desconecta.

    Te paso mi configuracion:

    oscam.conf

    Código:
    [global]
    logfile                       = syslog;/usr/local/etc/oscam.log
    clienttimeout                 = 4000
    fallbacktimeout               = 1500
    nice                          = -1
    maxlogsize                    = 100
    preferlocalcards              = 2
    usrfile                       = /usr/local/etc/oscamuser.log
    lb_mode                       = 2
    lb_max_ecmcount               = 100
    lb_stat_cleanup               = 200
    lb_max_readers                = 1
    lb_savepath                   = /usr/local/etc/stadistoscam.log
    ecmfmt                        = c&p/d/s/l:h
    
    
    [cache]
    
    
    [newcamd]
    port                          = 16800@0500:041700
    key                           = 0102030405060708091011121314
    keepalive                     = 1
    
    
    [cccam]
    port                          = xxxxx
    nodeid                        = Exxxxxxxxxx
    version                       = 2.2.1
    reshare                       = 1
    stealth                       = 1
    
    
    [dvbapi]
    enabled                       = 1
    user                          = xxxx
    
    
    [webif]
    httpport                      = xxxxx
    httpuser                      = xxxxxxx
    httppwd                       = xxxxxxx
    httprefresh                   = 60
    httpallowed                   = 0.0.0.0-255.255.255.0
    oscam.server

    Código:
    [reader]
    label                         = freex
    protocol                      = newcamd
    device                        = 192.168.1.x,xxxxx
    key                           = 0102030405060708091011121314
    user                          = xxxxx
    password                      = xxxxx
    inactivitytimeout             = 0
    disableserverfilter           = 1
    connectoninit                 = 1
    keepalive                     = 1
    ident                         = 0500:041700
    group                         = 1


    Citar Citar  

  15. #10
    Avatar de miquelcamps

    miquelcamps está desconectado
    Título:  Amigo de Lonas Rango:  Amigo de Lonas
    Fecha de ingreso
    Oct-2006
    Receptor
    VU+uno
    Firmware
    OpenVix
    Ubicación
    Catalunya
    Temas
    4
    Mensajes
    50


    Si lo he entendido bien; tienes un deco con sbox y tu card, y en otra habitacion tienes otro con oscam, desde el deco de sbox le quieres pasar una Nline al que tienes con oscam, y supongo que quieres ver con el dvbapi de oscam ¿no?
    te pondré una configuracion que a mi me funciona bien:

    oscam.conf
    Código:
    [global]
    logfile                       = stdout;/usr/log/oscam/oscam.log
    disableuserfile               = 0
    usrfileflag                   = 1
    fallbacktimeout               = 1500
    clientmaxidle                 = 0
    bindwait                      = 10
    unlockparental                = 1
    nice                          = -1
    maxlogsize                    = 1000
    readerrestartseconds          = 1
    dropdups                      = 1
    block_same_ip                 = 0
    block_same_name               = 0
    usrfile                       = /usr/log/oscam/oscam.log
    cwlogdir                      = /usr/log/oscam/cw
    lb_mode                       = 1
    lb_save                       = 1000
    lb_nbest_readers              = 2
    lb_nfb_readers                = 2
    lb_max_ecmcount               = 200
    lb_retrylimit                 = 600
    lb_max_readers                = 4
    lb_savepath                   = /tmp/stats
    
    
    [newcamd]
     port                          = 16800@0500:041700 
    key                            = 0102030405060708091011121314 
    keepalive                     = 1
    
    [dvbapi]
    enabled                       = 1
    request_mode                  = 0
    user                          = xxxx 
    boxtype                       = dreambox
    lo demas dejalo como lo tienes

    oscam.server

    Código:
    [reader]
    label                         = freex
    protocol                      = newcamd
    device                        = 192.168.1.x,xxxx
    key                           = 0102030405060708091011121314
    user                          = xxxxx
    password                      = xxxxx
    connectoninit                 = 1
    ident                         = 0500:041700
    group                         = 1
    prueba de esta forma a ver que tal
    Última edición por miquelcamps; 07-02-15 a las 15:54


    Citar Citar  

  16. Los siguientes usuarios agradecieron a miquelcamps por su mensaje :

    Odonk (07-02-15)

  17. #11
    Avatar de miquelcamps

    miquelcamps está desconectado
    Título:  Amigo de Lonas Rango:  Amigo de Lonas
    Fecha de ingreso
    Oct-2006
    Receptor
    VU+uno
    Firmware
    OpenVix
    Ubicación
    Catalunya
    Temas
    4
    Mensajes
    50


    En el dvbapi en boxtype tienes que poner segun tu tipo de deco, he puesto dreambox que es para mipsel en general, si no es tu caso cambialo al tuyo


    Citar Citar  

  18. Los siguientes usuarios agradecieron a miquelcamps por su mensaje :

    Odonk (07-02-15)

  19. #12
    Avatar de Odonk

    Odonk ha iniciado este hilo.
    Odonk está desconectado
    Título:  Amigo de Lonas Rango:  Amigo de Lonas
    Fecha de ingreso
    Apr-2011
    Nacionalidad
    Espana
    Temas
    7
    Mensajes
    69


    Lo uso en una raspberry pi, realmente deberia eliminar el dvbapi porque no se usa. No creo que eso tenga que ver con la Nline.


    Citar Citar  

  20. #13
    Avatar de miquelcamps

    miquelcamps está desconectado
    Título:  Amigo de Lonas Rango:  Amigo de Lonas
    Fecha de ingreso
    Oct-2006
    Receptor
    VU+uno
    Firmware
    OpenVix
    Ubicación
    Catalunya
    Temas
    4
    Mensajes
    50


    Si no vas a ver con la raspberry quita el dvbapi
    cuando he visto en tu confi que tenias dvbapi he supuesto que querias ver con el oscam, como no habias puesto en que clase de dispositivo tenias oscam...


    Citar Citar  

  21. Los siguientes usuarios agradecieron a miquelcamps por su mensaje :

    Odonk (07-02-15)

  22. #14
    Avatar de Odonk

    Odonk ha iniciado este hilo.
    Odonk está desconectado
    Título:  Amigo de Lonas Rango:  Amigo de Lonas
    Fecha de ingreso
    Apr-2011
    Nacionalidad
    Espana
    Temas
    7
    Mensajes
    69


    Eliminado dvbapi y se sigue desconectando la Nline.


    Citar Citar  

  23. #15
    Avatar de miquelcamps

    miquelcamps está desconectado
    Título:  Amigo de Lonas Rango:  Amigo de Lonas
    Fecha de ingreso
    Oct-2006
    Receptor
    VU+uno
    Firmware
    OpenVix
    Ubicación
    Catalunya
    Temas
    4
    Mensajes
    50


    Si el dvbapi no te soluciona lo de la N, es solo por si querias ver con oscam.
    Has probado la confi que te he puesto arriba?


    Citar Citar  

  24. Los siguientes usuarios agradecieron a miquelcamps por su mensaje :

    Odonk (07-02-15)

  25. #16
    Avatar de Odonk

    Odonk ha iniciado este hilo.
    Odonk está desconectado
    Título:  Amigo de Lonas Rango:  Amigo de Lonas
    Fecha de ingreso
    Apr-2011
    Nacionalidad
    Espana
    Temas
    7
    Mensajes
    69


    Si, la probe y hace lo mismo. Ahora me pone esto en el log:


    • xxxxxxxxxxxxxxxxxxxx [newcamd] disconnected: reason receive error1
    • xxxxxxxxxxxxxxxxxxxx p Connection closed to remote server


    Citar Citar  

  26. #17
    Avatar de miquelcamps

    miquelcamps está desconectado
    Título:  Amigo de Lonas Rango:  Amigo de Lonas
    Fecha de ingreso
    Oct-2006
    Receptor
    VU+uno
    Firmware
    OpenVix
    Ubicación
    Catalunya
    Temas
    4
    Mensajes
    50


    Puedes pasarme esa N por privado y la pruebo en mi server para ver si me pasa lo mismo??


    Citar Citar  

  27. Los siguientes usuarios agradecieron a miquelcamps por su mensaje :

    Odonk (07-02-15)

  28. #18
    Avatar de Odonk

    Odonk ha iniciado este hilo.
    Odonk está desconectado
    Título:  Amigo de Lonas Rango:  Amigo de Lonas
    Fecha de ingreso
    Apr-2011
    Nacionalidad
    Espana
    Temas
    7
    Mensajes
    69


    Eso no me resulve nada. Pongamos que te funciona. Si a mi no me funciona no me sirve de nada. Y la N esta bien porque esta probada en otro aparato con CCcam.

    Gracias por tu interes. Yo casi que me doy por vencido. Estoy por abandonar Oscam y regresar a Sbox+CCcam


    Citar Citar  

  29. #19
    Avatar de miquelcamps

    miquelcamps está desconectado
    Título:  Amigo de Lonas Rango:  Amigo de Lonas
    Fecha de ingreso
    Oct-2006
    Receptor
    VU+uno
    Firmware
    OpenVix
    Ubicación
    Catalunya
    Temas
    4
    Mensajes
    50


    Como tu quieras, suerte


    Citar Citar  

  30. Los siguientes usuarios agradecieron a miquelcamps por su mensaje :

    Odonk (07-02-15)

  31. #20
    Avatar de hadesv

    hadesv está desconectado
    Título:  Usuario VIP Rango:  Usuario VIP
    Fecha de ingreso
    Jan-2012
    Nacionalidad
    Andorra
    Temas
    13
    Mensajes
    206


    puedes ponerme el reader entero de ese newcamd.. si quieres evita usuario y device..

    y la version de oscam


    Citar Citar  

Página 1 de 3 123 ÚltimoÚltimo
Subir