Resultados 1 al 1 de 1






Tema importante - adjuntar imágenes al foro


Estás en el tema Tema importante - adjuntar imágenes al foro dentro del subforo Anuncios y Novedades en LonasDigital. Nos encontramos ante un problema que no he podido solucionar aún pues me lo han reportado hoy mismo. El tema es el siguiente: Cuando nos mudamos al server nuevo, no solo se adquirió la máquina, también un certificado SSL para el dominio, pues bien, como la peña no paraba de decirme una y otra por privado que su navegador le decía que el sitio no era seguro, pues decidí añadir el sistema de caché que veis aquí. https://github.com/MegaManSec/IMG/blob/master/cache.php De modo que cuando...



Este tema tuvo 331 Visitas y 0 Respuestas

Actualmente hay 1 usuarios viendo este tema. (0 miembros y 1 visitantes)

  1. #1
    Avatar de lonas

    lonas ha iniciado este hilo.
    lonas está desconectado
    Título:  ✔ User Verified ™ Rango:  Admin & Developer
    Fecha de ingreso
    Sep-2006
    Receptor
    Formuler F1
    Firmware
    OpenLD-3.0
    Nacionalidad
    Espana
    Ubicación
    Planeta Marte
    Edad
    36
    Temas
    1614
    Mensajes
    23,416


    Nos encontramos ante un problema que no he podido solucionar aún pues me lo han reportado hoy mismo.

    El tema es el siguiente:

    Cuando nos mudamos al server nuevo, no solo se adquirió la máquina, también un certificado SSL para el dominio, pues bien, como la peña no paraba de decirme una y otra por privado que su navegador le decía que el sitio no era seguro, pues decidí añadir el sistema de caché que veis aquí. https://github.com/MegaManSec/IMG/blob/master/cache.php

    De modo que cuando el foro detectaba un hilo donde existiese una imagen que no fuera SSL la modificase no mostrando esta y en su defecto mostrando esta imagen:



    y si daba problemas la image o el enlace no rulaba como corresponde pues esta otra:



    Hasta aquí todo correcto, ya que la solución pasaba por alojar las imágenes en host tipo http://httpsimage.com/ que permiten alojar imágenes con SSL dentro del foro.

    Peeeero... Hoy me reportaron un tema y revisándolo me he dado cuenta que existe un gran problema con todo esto, pues si creas un post y añades una imagen y le das a enviar todo funciona de lujo, el problema viene cuando lo intentas editar, cada vez que editas o pulsas en cambiar editor a fuente, te añade un extra y otro y otro... Hasta que la image se convierte en lo que veis arriba que pone 404 - image not found.

    No puedo desactivar el sistema por que de cara a google nos penalizaría bastante la pérdida del SSL en tantos hilos, por lo que hasta que no encuentre una solución al tema, os ruego que solo añadan capturas de pantalla o imágenes que sean subidas mediante SSL.

    Se que desde tapatalk es una putada, lo se, con razón la mitad de post están ilegibles....

    El tema es que me pilla muy liado estos días como para poder dedicarle mucho tiempo a esto, así que disculpar por ello. Sólo quería notificarlo para aquellos que envista de este problema han desistido en seguir participando creyendo que el foro de algún modo les estaba puteando sus aportes.

    Intentaré darle una solución al respecto lo mas rápido posible. Si ven cosas extrañas estos días por el foro no asustarse que es el menda haciendo cambios y ajustes jeje.

    PD: usar solo host que os adjunten las imágenes en SSL please, por google hay unos cuantos: https://www.google.es/search?q=Free+..._sm=0&ie=UTF-8

    Seguramente termine creando yo nuestro propio upload de imágenes para así evitar todos estos problemas, pero mientras tanto evitar uploads que no sean seguros.

    Este problema solo sucede cuando se edita el post, o se le da a visualizar antes o se usan las opciones de cambiar el editor.

    Saludos

    Si te gustó este post, dale arriba a los botones de Me gusta (facebook) Twitter y google +1 que no te llevará ni 5 segundos xD

    Recuerda:
    El trabajo que realizo es de manera altruista y seguirá siendo así siempre, pero nunca viene mal un poco de ayuda,apoyo y motivación para continuar creando y creciendo en lo que uno realiza.
    Si estas satisfecho y te apetece,puedes contribuir con una donación :

    No se resuelven dudas por Privados ni por E-mail,las incidencias se consultan en el foro y se resuelven entre todos.

    Sígueme en Twitter: https://twitter.com/javilonas


    Citar Citar  

  2. Los siguientes 2 Usuarios dieron las gracias a lonas Por su Mensaje :

    kargom (03-11-15), lavadoras (03-11-15)


  3. QoinPro.com: Free Bitcoins every 24 hours


Subir