• Hola Guest, nos gustaría recordarte que mantener este sitio en línea conlleva unos gastos mensuales y anuales.

    Sin vuestra ayuda mensual no es posible seguir en pie, no hay mucho más que contar.

    Si quieres colaborar para que sea posible por lo menos seguir en pie como comunidad, puedes hacerlo mediante alguno de los métodos disponibles en esta página: https://www.lonasdigital.com/donaciones/

    Recuerda que si necesitas invitación para acceder al foro, puedes solicitarla en nuestro Grupo de Telegram


NCam 6.0-r0 (oficial)

Perfecto, gracias por la aclaración. Acabo de activar, iré viendo si veo algún cambio.

Lo que si he visto, aún abriendo el puerto del protocolo cs357x me sigue diciendo que está cerrado. Primero he pensado, sera que tengo parado el reader, pero he entrado en NCam y está en marcha y funcionando.

Lo que si he tenido que hacer el quitar la IP de localhost (127.0.0.1) y poner la del deco en los readers y en la config de NCam, sino me decía que estaban cerrados, pero con el cs357x ni con esas.
Como te comentaba antes jeje, temas de redes.... También me he tenido que pelear con algún que otro router y al final llamar a la compañía por que estaba metido en CGNAT y mierdas por el estilo.

También me he visto con un compi del foro en una igual con vodafone y los últimos routers que pusieron y la solución a los enlaces internos pasaba por dejarles la ip del deco 192.168.1.x. o andar jugando con las reglas del cortafuegos

Es lo que te decía antes, la experiencia muchas veces es un plus para evitar problemas que ya has pasado antes, por eso recomiendo abrirlos aunque sean a nivel interno. Te puedes volver loco si no entiendes algo. Si ya de por si es lioso para muchos poner en marcha un softcam, diles que encima no les funciona por que tienen los puertos del router cerrados jeje, les puede dar de todo menos la risa.

Saludos
 
Que va, si soy server, puedo apagar un usuario, pero estaria genial apagarle el deco.
Hay alguno que no tiene bien la parabolica, que no apaga el deco nunca, que...., y soy de los que le gusta tener el control de todo xD

en Cataluña y Baleares es fiesta total xD
Coño jeje ¿no te es suficiente con apagarle la línea del cliente xD? a esos que no apagan el deco nunca y siguen haciendo peticiones, les dices que configuren un script o algún cron para que el deco por la noche se ponga en canal sur o algún canal FTA y santas pascuas y muy a las malas, si te sabes la password tú mismo jeje, pero no necesitas un botón para eso en Ncam pienso yo. Me parece un poco hardcore :p

También puedes apañarte tú algo para detenerles por las noches las peticiones, no sé hay más opciones pienso yo jeje

Ya decía yo, aquí en Andalucía toca currar, luego dicen que tenemos más fiesta que nadie jejeje

Saludos
 
Como te comentaba antes jeje, temas de redes.... También me he tenido que pelear con algún que otro router y al final llamar a la compañía por que estaba metido en CGNAT y mierdas por el estilo.

También me he visto con un compi del foro en una igual con vodafone y los últimos routers que pusieron y la solución a los enlaces internos pasaba por dejarles la ip del deco 192.168.1.x. o andar jugando con las reglas del cortafuegos

Es lo que te decía antes, la experiencia muchas veces es un plus para evitar problemas que ya has pasado antes, por eso recomiendo abrirlos aunque sean a nivel interno. Te puedes volver loco si no entiendes algo. Si ya de por si es lioso para muchos poner en marcha un softcam, diles que encima no les funciona por que tienen los puertos del router cerrados jeje, les puede dar de todo menos la risa.

Saludos
Es algún misterio con el protocolo cs357x. He cruzado los puertos con el cs378x y el puerto que antes salía como cerrado, ahora lo abre y el otro ahora no lo abre, vaya misterio .

Tengo de router un Mikrotik conectado directamente a la ONT del proveedor, hace tiempo que me cansé de routers de proveedores.

No tendrá que ver con algo de config?

Gracias por todo compañero
 
yo ya me pierdo con tantas configuraciones.....alguna configuracion standar y que parametros con los que jugar, para gente como yo, que solo tenemos lineas de oriente y no tenemos plastico??? me pongo a leer y veo que lo mismo estais jugando con parametros mezclando configuraciones donde conviven plasticos con lineas,server con clientes......
esque ya estais hablando a un nivel que la mayoria no llegamos por desgracia...
 
¿Tocaste algo más? se ve bastante bien y tiempos muy buenos, creo que te leí el otro día que habías modifcado más cosas.
Buenas,
Quite, como me comentaste:
[reader]
label = Card_Blanca
description = Card_Blanca
protocol = ncam

Así, que tengo sólo,
[reader]
label = Card-Scam
protocol = scam

[reader]
label = Camd35
protocol = cs357x

[reader]
label = Camd38
protocol = cs378x

[reader]
label = cacheex
description = Cachex DO NOT DELETE
protocol = cs378x

con sus users correspondientes,

Más, mis lineas cccam

Si, pongo nuevamente cambios.
Yo filtro reader externos caid:1810

[global]
logfile = /dev/null
clienttimeout = 12000
fallbacktimeout = 1300
bindwait = 60
netprio = 10 # sólo me funciona, valor 0 ó 10, pienso que cosa de mi red
nice = -10
waitforcards_extra_delay = 260
preferlocalcards = 1
readerrestartseconds = 4
lb_nbest_readers = 3
lb_nfb_readers = 4
lb_min_ecmcount = 5
lb_retrylimit = 600
lb_max_readers = 1
lb_savepath = /tmp/stats
double_check_caid = 0100,1810
ecmfmt = DATA=c@p/i/s ECM_L:l CW=w HOP=j
suppresscmd08 = 1
disablecrccws_only_for = 0500:020810,030830,030B00,032830,032840,032900,032920,032930,032940,032950,041A00,041900,041950,041A30,042800,042820,043330,051B00,060D00;098C:000000;09C4:000000;098D:000000;0E00:000000;1811:003311,003315,023311,003341,00331B,000007,000107;0100:003311,00006C,00006D;1817:000000,00006A;1818:000000,00006C,000007;1819:000000,00006D,000007;1863:003342,003343;1883:003311,003315,003317,003342,003343;1884:000000,000068;1709:000000;1708:000000;0604:000000;0E00:000000;1810:000000;0100:004106

[cache]
delay = 100
cw_cache_size = 2700
cw_cache_memory = 5
cw_cache_settings = 0:2:4000
ecm_cache_size = 2700
ecm_cache_memory = 5

ecm_cache_droptime = 1
max_hit_time = 45
wait_time = 1810:150:750
cacheexenablestats = 1
cacheex_dropdiffs = 1
csp_port = 22155
csp_serverip = 127.0.0.1
csp_allow_request = 0
cacheex_cw_check = 0:0:1
wait_until_ctimeout = 1
csp_block_fakecws = 1
cacheex_nopushafter = 1810:850
waittime_block_start = 3
waittime_block_time = 4
cwcycle_check_enable = 1
cwcycle_check_caid = 0100,1810
cwcycle_maxlist = 4000
cwcycle_keeptime = 20

cwcycle_usecwcfromce = 1

Ademas, quito de todos reader y users las lineas:
services = movistar+_1810,movistar+_ppv_1810
lb_whitelist_services = movistar+_1810,movistar+_ppv_1810
lb_priority_services = movistar+_1810,movistar+_ppv_1810
disablecrccws_only_for = 1810:000000


Ayer, aunque mencione que introducia en users, la linea:
preferlocalcards = 1

Al final, no lo probe.

Hoy, si probare éste cambio, pero sólo en:
preferlocalcards = 1
users camd35:
users scam:
users camd38:

saludos
 
Gracias por la aclaracion javi,los reader van bien,he provado con un reader a un amigo y envia el cahe al servidor perfectamente,estoy retocando la configuracion y ya los tiempos lo tengo a una media de 0.3 y 0.4,vamos una pasada el Ncam.saludos...
 
Antes de morir en el intento... voy a ver si me aclaro con los grupos.
Sería factible este esquema ?

2 usuarios usan el protocolo CCCam para conectarse con Ncam
2 Usuarios usan el protocolo Newcamd para conectase con Ncam

Actualmente (almenos a mi) los readers Scam, camd35, camd38 y Card-Blanca, pintan "la misma peticion" de CW.

Se podría destinar 2 readers a hablar solo con newcamd y generar cache, y luego otros 2 a hablar solo con los CCCam y generar otro caché.

Y aprovechar el caché conjuntamente los 4 ?


Por cierto, cambiando el netprio a 10, mis tiempos han bajado considerablemente tambien
 
Last edited:
Gracias por la aclaracion javi,los reader van bien,he provado con un reader a un amigo y envia el cahe al servidor perfectamente,estoy retocando la configuracion y ya los tiempos lo tengo a una media de 0.3 y 0.4,vamos una pasada el Ncam.saludos...
Cuando acabes, podrias pasar la configuracion ?

muchas gracias!
 
Perfecto, gracias por la aclaración. Acabo de activar, iré viendo si veo algún cambio.

Lo que si he visto, aún abriendo el puerto del protocolo cs357x me sigue diciendo que está cerrado. Primero he pensado, sera que tengo parado el reader, pero he entrado en NCam y está en marcha y funcionando.

Lo que si he tenido que hacer el quitar la IP de localhost (127.0.0.1) y poner la del deco en los readers y en la config de NCam, sino me decía que estaban cerrados, pero con el cs357x ni con esas.
Buenas,

Yo tengo esto en mi configuracion, es firmware de FreshTomato,

wan-settings.jpg



red.jpg
 
Últimamente desde ayer recibo muchísimos timeouts, no sé si es cosa mía o es que el botón cada vez está más pulsado.
Dejo el log.
 
Últimamente desde ayer recibo muchísimos timeouts, no sé si es cosa mía o es que el botón cada vez está más pulsado.
Dejo el log.
ahroa mismo esta todo operativo, es cosa de tus lineas. Has probado a quitar el modo1 de tus user/reader?
 
Es algún misterio con el protocolo cs357x. He cruzado los puertos con el cs378x y el puerto que antes salía como cerrado, ahora lo abre y el otro ahora no lo abre, vaya misterio .

Tengo de router un Mikrotik conectado directamente a la ONT del proveedor, hace tiempo que me cansé de routers de proveedores.

No tendrá que ver con algo de config?

Gracias por todo compañero
Los router ajenos a las compañías, por desgracia siguen conectados a la centralita, aunque mejores en seguridad, libertad de configuración y demás, sigues limitado a una centralita y sus restricciones, También te puedes meter dentro y trastear en algunas jeje.

También llevo años sin usar los routers que coloca la operadora, me pongan centralita o no, todo pasa por un router neutro antes. Y los problemas que te he comentado los he sufrido igualmente, hasta una pollada tan simple como un cambio de DNS con menos restricciones me ha solventado alguna que otra pajarraca extraña que me tenía loco.

¿Puede tratarse de configuración? puede ser, pero ¿qué tocaste? por que tal y como está en los archivos por defecto, abriendo los puertos como te digo, funciona sin problemas. Puede ser cosa del protocolo, no te lo discuto, incluso puede estar relacionado con el modo net prio en la config global del NCam o la de tu propio router que tengas seleccionado por defecto. Aunque yo personalmente no tengo problemas de conectarme ni por uno ni por otro, ni en el VPS ni en el deco.

Habría que indagar más en el tema ¿tienes las conexiones IPV6 desactivadas en el router? o ¿está operativo IP`V6 aunque no lo uses? es por ir descartando cosas.

Dices que cambiando el puerto en los protocolos, te ha salido andando... Y luego el otro que iba ya no rula, es decir al contrario, intenta probar otro puerto diferente, quizás esté siendo usado el que has seleccionado por algún servicio y lo desconoces o quizás es como dices, tema de configuración, user, pass, etc...

Intenta conectarte primero con usuario y password no muy retorcido, sin mayúsculas ni valores extraños y cuando lo tengas andando ya lo pones como quieras, todo por ir descartando temas.

Saludos
 
yo ya me pierdo con tantas configuraciones.....alguna configuracion standar y que parametros con los que jugar, para gente como yo, que solo tenemos lineas de oriente y no tenemos plastico??? me pongo a leer y veo que lo mismo estais jugando con parametros mezclando configuraciones donde conviven plasticos con lineas,server con clientes......
esque ya estais hablando a un nivel que la mayoria no llegamos por desgracia...
Las que trae por defecto ls archivos de configuración. No tienes más que añadir tus reader y configurar la IP de tu deco, puertos, passwords y poco más.
 
Buenos días,

Antes de nada agradecer a Javi su esfuerzo por este desarrollo.

Dentro mi mis modestos conocimientos y mis ganas de cacharrear, observo en el log estas líneas

  • 2022-04-18 11:51:20 00000000 s (config) skipping fake cw fff67c7dea0d59e8450ef97b0f1484c3 because of wrong checksum!
  • 2022-04-18 11:51:20 00000000 s (config) skipping fake cw fffa7fff2efdfff78a2219c5de98ab21 because of wrong checksum!
  • 2022-04-18 11:51:20 00000000 s (config) skipping fake cw ffffffffffffffffffffffffffffffff because of wrong checksum!
  • 2022-04-18 11:51:21 00000000 s (config) 20046 fakecws's loaded
Precedidas de un montón como esas de "skipping fake cw".

Estoy con la v 6.0.

Esto a que es debido? Tengo que cambiar algo?

Muchas gracias
 
Buenas,
Quite, como me comentaste:
[reader]
label = Card_Blanca
description = Card_Blanca
protocol = ncam

Así, que tengo sólo,
[reader]
label = Card-Scam
protocol = scam

[reader]
label = Camd35
protocol = cs357x

[reader]
label = Camd38
protocol = cs378x

[reader]
label = cacheex
description = Cachex DO NOT DELETE
protocol = cs378x

con sus users correspondientes,

Más, mis lineas cccam

Si, pongo nuevamente cambios.
Yo filtro reader externos caid:1810

[global]
logfile = /dev/null
clienttimeout = 12000
fallbacktimeout = 1300
bindwait = 60
netprio = 10 # sólo me funciona, valor 0 ó 10, pienso que cosa de mi red
nice = -10
waitforcards_extra_delay = 260
preferlocalcards = 1
readerrestartseconds = 4
lb_nbest_readers = 3
lb_nfb_readers = 4
lb_min_ecmcount = 5
lb_retrylimit = 600
lb_max_readers = 1
lb_savepath = /tmp/stats
double_check_caid = 0100,1810
ecmfmt = DATA=c@p/i/s ECM_L:l CW=w HOP=j
suppresscmd08 = 1
disablecrccws_only_for = 0500:020810,030830,030B00,032830,032840,032900,032920,032930,032940,032950,041A00,041900,041950,041A30,042800,042820,043330,051B00,060D00;098C:000000;09C4:000000;098D:000000;0E00:000000;1811:003311,003315,023311,003341,00331B,000007,000107;0100:003311,00006C,00006D;1817:000000,00006A;1818:000000,00006C,000007;1819:000000,00006D,000007;1863:003342,003343;1883:003311,003315,003317,003342,003343;1884:000000,000068;1709:000000;1708:000000;0604:000000;0E00:000000;1810:000000;0100:004106

[cache]
delay = 100
cw_cache_size = 2700
cw_cache_memory = 5
cw_cache_settings = 0:2:4000
ecm_cache_size = 2700
ecm_cache_memory = 5

ecm_cache_droptime = 1
max_hit_time = 45
wait_time = 1810:150:750
cacheexenablestats = 1
cacheex_dropdiffs = 1
csp_port = 22155
csp_serverip = 127.0.0.1
csp_allow_request = 0
cacheex_cw_check = 0:0:1
wait_until_ctimeout = 1
csp_block_fakecws = 1
cacheex_nopushafter = 1810:850
waittime_block_start = 3
waittime_block_time = 4
cwcycle_check_enable = 1
cwcycle_check_caid = 0100,1810
cwcycle_maxlist = 4000
cwcycle_keeptime = 20

cwcycle_usecwcfromce = 1

Ademas, quito de todos reader y users las lineas:
services = movistar+_1810,movistar+_ppv_1810
lb_whitelist_services = movistar+_1810,movistar+_ppv_1810
lb_priority_services = movistar+_1810,movistar+_ppv_1810
disablecrccws_only_for = 1810:000000


Ayer, aunque mencione que introducia en users, la linea:
preferlocalcards = 1

Al final, no lo probe.

Hoy, si probare éste cambio, pero sólo en:
preferlocalcards = 1
users camd35:
users scam:
users camd38:

saludos
Yo si he estado probando en los usuarios igual que en el global el modo 1.
Pero no iba tan fino o eso al menos pienso, tampoco es que le haya dado mucho tiempo a ello jeje, pero ya me contarás que tal.

Los tiempos que me enseñaste ayer están bastante bien, la verdad jeje
 
Esta es la configuracion que he puesto,he añadido el Faiban para evitar conexiones no autorizadas y el modo sleep para que mande a dormir al tipico que se deja un canal puesto,asi no tira del servidor y el wait_time del cache lo he desabilitado de momento,hire jugando hasta dejarlo fino.Ahora tengo otra duda,en el ncam.conf se le puede añadir alguna linea para que busque los config en un directorio en concreto?por ejemplo si creo en la raiz un directorio llamado ncam y dentro creo ncam lector y otro ncam server,para que cuando reinicie la web pille los config de su directorio por ejemplo con este el log se va a su sitio: usrfile = /ncam/ncam_lector/config/oscamuser.log.La media con esta configuracion es de 300 a 500ms.
# ncam.conf generated automatically by NCAM 6.0
# Read more: https://www.lonasdigital.com
[global]
logfile = /dev/null
clienttimeout = 9000
fallbacktimeout = 9000
sleep = 120
bindwait = 60
netprio = 2
nice = -1
maxlogsize = 1024
dropdups = 1
waitforcards_extra_delay = 260
preferlocalcards = 1
readerrestartseconds = 4
lb_nbest_readers = 3
lb_mode = 1
lb_save = 500
lb_auto_betatunnel_prefer_beta= 200
failbantime = 1440
failbancount = 3
lb_nfb_readers = 4
lb_min_ecmcount = 5
lb_retrylimit = 600
lb_max_readers = 1
lb_savepath = /tmp/stats
double_check_caid = 0100,0500,1811,09C4,098C,1830,1843,1810
ecmfmt = DATA=c@p/i/s ECM_L:l CW=w HOP=j
suppresscmd08 = 1
disablecrccws_only_for = 0500:020810,030830,030B00,032830,032840,032900,032920,032930,032940,032950,041A00,041900,041950,041A30,042800,042820,043330,051B00,060D00;098C:000000;09C4:000000;098D:000000;0E00:000000;1811:003311,003315,023311,003341,00331B,000007,000107;0100:003311,00006C,00006D;1817:000000,00006A;1818:000000,00006C,000007;1819:000000,00006D,000007;1863:003342,003343;1883:003311,003315,003317,003342,003343;1884:000000,000068;1709:000000;1708:000000;0604:000000;0E00:000000;1810:000000;0100:004106

[cache]
delay = 100
max_time = 22
cw_cache_size = 4000
cw_cache_memory = 8
cw_cache_settings 1810:2:550
ecm_cache_size = 4000
ecm_cache_memory = 8
ecm_cache_droptime = 1
max_hit_time = 60
#wait_time = 1810:300:700
cacheex_dropdiffs = 1
cacheex_ecm_filter = 1810@000000,4001
csp_port = 20090
csp_serverip = 192.168.1.31
csp_allow_request = 0
cacheex_cw_check = 1810:2:2000
wait_until_ctimeout = 1
csp_block_fakecws = 1
cacheex_nopushafter = 1810:550
waittime_block_start = 5
waittime_block_time = 8
cwcycle_check_enable = 1
cwcycle_check_caid 1810
cwcycle_maxlist = 550
cwcycle_sensitive = 2
cwcycle_usecwcfromce = 1
 
Last edited:
Antes de morir en el intento... voy a ver si me aclaro con los grupos.
Sería factible este esquema ?

2 usuarios usan el protocolo CCCam para conectarse con Ncam
2 Usuarios usan el protocolo Newcamd para conectase con Ncam

Actualmente (almenos a mi) los readers Scam, camd35, camd38 y Card-Blanca, pintan "la misma peticion" de CW.

Se podría destinar 2 readers a hablar solo con newcamd y generar cache, y luego otros 2 a hablar solo con los CCCam y generar otro caché.

Y aprovechar el caché conjuntamente los 4 ?


Por cierto, cambiando el netprio a 10, mis tiempos han bajado considerablemente tambien
El net prio, lo primero que hay que hacer es mirar cual tienes en tu propio router, es una optimización a nivel interno que depende más de tu red que de otra cosa.

Yo cuando monto algún ncam en servidores dedicados/VPS suelo hacer uso de 10/11/12 la mayoría de veces, aunque algunos servidores dedicados funcionan incluso mejor con 14/15/16.
Y en decos, antes de hacer nada, suelo fijarme en la configuración del router si existe opción alguna ya preconfigurada en las opciones avanzadas por defecto para poner una u otra, ncam trae por defecto el 2 por ser algo standarizado y global para la mayoría de casos. Pero no significa que sea la mejor opción para todos, es como el Nice, en el deco por ejemplo llevo -10 pero en el VPS -15 hace que vaya mucho más relajado NCam.

Siempre digo lo mismo, todo es probar cada uno que le funciona mejor o peor, a diferencia de CCcam, Oscam/Ncam tiene muchas opciones y configuraciones y es complicado dejar una global que a todos les funcione de igual modo, pero aún así es lo que se intenta jeje.

2 usuarios tirando de CCcam y otros 2 de newcamd, puedes luego jugar con los usuarios y repartir lo que tu quieras al que tu quieras.

Con la caché lo mismo, pero la caché interna, quien las genera son las líneas que dices que pintan la misma petición, las otras generan su propia caché. Por lo que sería factible compartir la caché interna luego conjuntamente para los otros 4.

Todo es ponerse jeje
 
Últimamente desde ayer recibo muchísimos timeouts, no sé si es cosa mía o es que el botón cada vez está más pulsado.
Dejo el log.
Por seguridad te eliminé el log, había detalles demasiado privados en el mismo jeje.

Prueba a desactivar las líneas internas, los servidores que te están dando chicha parece ser que no son muy estables, preferible en estos casos tirar directamente de ellos para aminorar los tiempos entre timeouts y resets.
 
Buenos días,

Antes de nada agradecer a Javi su esfuerzo por este desarrollo.

Dentro mi mis modestos conocimientos y mis ganas de cacharrear, observo en el log estas líneas


Precedidas de un montón como esas de "skipping fake cw".

Estoy con la v 6.0.

Esto a que es debido? Tengo que cambiar algo?

Muchas gracias
Ese log es normal, te está indicando que en el archivo donde se filtran las CW fake, existen esas y que el sistema por defecto las omitirá ya que el checksum (la suma de verificación/comprobación) no es correcta, por eso están en ese archivo almacenados.

Y aunque parezca que ese archivo no hace nada, si lo hace. La confusión es entendible causada por el log.

Lo que sucede es que en la codificación interna de NCam al igual que en oscam, está puesto para que por defecto cuando haga un timeout o un NOK termine con un return 0 que hace que en el log escupa las CW a 0, por eso estáis viendo los CW=00000000000000000000000000000000 , no por que el proveedor esté enviando esas CW y eso os puede explicar lo que más de uno se habrá preguntado (y leo por grupos de telegram), si ese CW está en el archivo de los fake ¿por qué sigue tragándoselos?, la respuesta es sencilla, no se los está tragando (aunque algunos digan que ese archivo no hace nada), el LOG escupe un 0 por que es lo que tiene programado que haga, si queréis que escupa yo que sé... NULL (bueno null no que quizás pete todo jeje) o CW=Timeout o lo que sea, es tan fácil como cambiarlo, pero ese 0 en concreto del LOG no es una CW real. Ya os lo adelanto yo para disipar dudas.

En el caso de NCam, aparte de eso, en la versión 6.1, cuando esto sucede, he usado ese return para poder fijar que cuando esto suceda, resetee el cliente o reader afectado.
Puede ser que con resetear sólo el reader hubiera sido suficiente, pero para eso están los TEST jeje, en el próximo quizás añada una opción en los reader o clientes y que cada uno decida si quiere que lo haga o no. O igual dejo que lo haga siempre con los readers que sería lo ideal.

Saludos
 
@lonas y existe alguna posibilidad de quitar el
Code:
2022-04-18 12:25:26 00000000 s   (config) skipping fake cw XXXXX because of wrong checksum!

Del log? He activado el log en fichero para hacer un poco de seguimiento más profundo y cada vez que se reinicia NCam lo peta xD.
 

Similar threads

Javilonas
Replies
653
Views
75K
rgchurion
R
Javilonas
Replies
65
Views
5K
olecram1315
O
Javilonas
Replies
48
Views
4K
Javilonas
Javilonas
Javilonas
Replies
188
Views
25K
Javilonas
Javilonas
Javilonas
Replies
141
Views
14K
Codec
C
Javilonas
Replies
382
Views
29K
anatulfo
anatulfo
Back
Top